Browsers, Desktop, Linux, Ubuntu, Web

Instalando o novo Flash player 9 com fullscreen, aceleração 3d e h.264

Flash Player Penguim

Já fazia um tempo que a Adobe não lançava um update compatível com o Flash para Windows e Mac, desde que lançou a primeira versão do Flash 9 para Linux.

As versões Windows e Mac tinham suporte a Fullscreen. Agora a versão para Linux também possui. Além disso podemos destacar suporte a aceleração por hardware de vídeo (esperamos que o flash consuma menos recursos do PC, porque antes, mesmo na versão 9, ainda era um “comedor” de recursos) e suporte ao codec H.264, possibilitando streaming (transmissão) de vídeos com alta resolução e tamanho reduzido.

Bom, chega de papo. Vamos ao que interessa. O objetivo é instalar a nova versão. Os passos são simples e deve funcionar para maior parte dos Linux (testado no Ubuntu).

1. No terminal (Aplicativos > Acessórios > Terminal), digite:

cd /tmp
wget http://tinyurl.com/yubwzq

2. Descompacte:

tar -xzvf flashplayer9_install_linux_082207.tar.gz

Obs.: Confira o nome do arquivo com o comando “ls | grep flash”

3. Copiando os arquivos:

cd /usr/lib/flashplugin-nonfree/ || \
sudo mkdir -p /usr/lib/flashplugin-nonfree/ && \
cd /usr/lib/flashplugin-nonfree/

sudo cp /tmp/install_flash_player_9_linux/libflashplayer.so .
sudo cp /tmp/install_flash_player_9_linux/flashplayer.xpt .
sudo chmod +x *flashplayer*

Obs.: os 3 primeiros comandos só executam quando o 3 executa.

4. Se você não tinha o Flash instalado execute:

ln -sf /usr/lib/flashplugin-nonfree/libflashplayer.so \
/usr/lib/firefox/plugins/libflashplayer.so
ln -sf /usr/lib/flashplugin-nonfree/flashplayer.xpt \
/usr/lib/firefox/plugins/flashplayer.xpt

ln -sf /usr/lib/flashplugin-nonfree/libflashplayer.so \
/usr/lib/mozilla/plugins/libflashplayer.so
ln -sf /usr/lib/flashplugin-nonfree/flashplayer.xpt \
/usr/lib/mozilla/plugins/flashplayer.xpt

Obs.: Novamente, não se preocupe se não você não ver resultado logo no primeiro comando, eles estão condicionados.

Se alguém não conseguiu instalar, pode tentar o script automático instala_flash9_up3.sh. Para executá-lo, digite:

chmod +x instala_flash.sh
sudo ./instala_flash.sh

Obs.: Se voce tiver problemas com o som, tente o comando abaixo:

sudo apt-get install libasound2-dev libssl-dev

Update: Parece que essa versão veio sem suporte de script, não sei porque e não sei no que isso afeta o funcionamento, já que o .xpt do flash 9 está no meu firefox e mozilla (leia-se derivados do mozilla). Alterei o post e o script. Se alguém tiver informações mais precisa eu altero aqui. Mais sobre o flash no Mozilla e derivados: http://plugindoc.mozdev.org/faqs/flash.html

Anúncios
Padrão