Bug, Dicas, Gnome, Linux, Ubuntu

Dica: Problema de desempenho Edgy e Feisty

Devido a um bug no Gnome, que faz com que a interface de loopback (lo) não seja reconhecida por alguns programas (atualmente 127.0.1.1 está sendo usado para o nome da máquina, ao invés do antigo 127.0.0.1, e alguns programas não estavam adaptados a isso), algumas coisas estavam mais devagar do que deveriam estar.

Para corrigir é simples. Na verdade, um tanto quanto bobo. Basta editar o arquivo /etc/hosts:

sudo gedit /etc/hosts

Você deve ver algo como:

127.0.0.1 localhost
127.0.1.1 nome-do-computador

Basta adicionar o nome do seu computador em frente ao localhost, ficando assim:

127.0.0.1 localhost nome-do-computador
127.0.1.1 nome-do-computador

Repetindo nome-do-computador, você garante que mesmo um programa não adaptado para usar o 127.0.1.1 possa achar nome-do-computador e vice-versa, mantendo a compatibilidade.

Veja agora se o seu terminal e nautilus carregam mais rápido, principalmente quando você ja tem vários programas rodando e já está com o sistema ligado a um tempo. Aqui a melhora foi significantemente grande para ser notada sem usar um benchmark, apenas “no olho”.

Obs.: Este bug não afeta, porém, o Dapper. Apenas o Edgy e Feisty. Se você tiver no Dapper, veja se ele usa apenas o 127.0.0.1.

Fonte: http://ubuntuforums.org/showthread.php?t=388765

Anúncios
Padrão

16 comentários sobre “Dica: Problema de desempenho Edgy e Feisty

  1. Interessante esta informação
    depois que fiz algumas atualizações me meu feisty 2 aplicações que utilizo diariamente estão travando sendo que o abiword nem chega a carregar, será que poderia ser isto?
    bom ao chegar em casa eu verifico.

  2. Valeu Andre!

    Não sei como não vi isso. O LP ta redirecionando diretamente pro beta, então devo ter copiado o com o beta no endereço.

    Abraço

    Obs.: Qualquer um pode ser beta, basta se inscrever e ter a intenção de ajudar. Ai, a medida que você vai usando, você acha bugs e da reports. Mas achar bugs não é um requisito.

  3. pibarnas disse:

    Mano, vc merece o Nobel! Essa dica foi EXCELENTE. Com o Ubuntu, como tudo é quase automático, diferente do slack que eu usei por anos, eu simplesmente nunca tinha aberto o /etc/hosts. Nunca iria saber da mudança, portanto. VALEU MESMO!!

  4. Xterminator,

    como o Feisty não está nem em beta ainda, é possível que erros como esse acontecam.
    Geralmente quando isso ocorre tento reinstalar com apt-get ou aptitude.

    Pode ser que seja isso, mas pode ser que não. Pra saber só testando mesmo.
    Já tentou procurar nos foruns, no google, geralmente alguem já teve seu problema e as vezes até já deu um bug report. Se você não achar nenhum, seria interessante você dar um bug report que alguma solução vai aparecer.

    []s

  5. Pibarnas,

    Obrigado. Na verdade o que a Equipe do Ubuntu faz é criar coisas em cima, como menus, personalizações. Assim o sistema já vem pronto e é mais fácil para o usuário final.

    Mas, isso não exclue o fato de que tudo possa ser configurado na mão, pelo terminal, se você souber mexer.

    Tem muita gente que sabe mexer em config mas usa o Ubuntu, mas não quer dizer que eles não personalizem nada, pois quanto mais você sabe, mais você quer o sistema do seu jeito.

    []s

  6. Então Lucas o processo de reinstalação eu sempre faço para ver
    acho que vou ter instalar os pacotes dgb das aplicações que estão dando problemas, o abiword e o outro é o gxine para ver se consigo os erros pois nenhuma mensagem é exibida ao chamá-los pelo terminal, só vou poder reportar um bug com estas informações disponíveis.

  7. Ótimo Xterminator, faça isso. As vezes foi algum erro de dependência que os programas estão pelo fato de estar faltando alguma dependência no .deb. Não estou com nenhum dos dois instalados aqui, então não posso dizer que estão funcionando.

    Achou algo relacionado?

  8. Luis Otavio Lima Julio disse:

    Boa dica, sabe que ainda não tinha reparado isto no meu arquivos /etc/hosts. Toda vez que eu tinha que alternar entre uma rede e outra isto levava uma eternidade e ao selecionar a rede correta o sistema estabilizava, mas as vezes era necessário reiniciar o gnome, pois recebia algumas mensagens de erro de componentes. Com esta dica “meus problemas acabaram-se”. Obrigado.

  9. Normando Carvalho disse:

    Aqui no meu Dapper está exatamente como você sugeriu para a correção do problema. Duas linhas, a primeira (127.0.0.1) com localhost e o nome do computador e a segunda só com o nome do computador….

  10. Alex,

    não sei se isso pode ser um problema da versão 6.06.1, porque ela foi uma segunda versão do Dapper (6.06).

    Veja se isso melhora.

    Para ver a versão sua, vá em Sistema > Sobre o Ubuntu, ou executa “cat /etc/issue”.

    []s

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s